nix-setup/configuration.nix
2024-09-07 01:18:31 +02:00

183 lines
5.6 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

# Edit this configuration file to define what should be installed on
# your system. Help is available in the configuration.nix(5) man page, on
# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
{ config, lib, pkgs, ... }:
{
imports =
[ # Include the results of the hardware scan.
./hardware-configuration.nix
./home.nix
];
# List packages installed in system profile. To search, run:
# $ nix search wget
environment.systemPackages = with pkgs; [
vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
helix
wget
alacritty
links2
fish
killall
bat
dconf
twemoji-color-font
fira-code
htop
rustup
clang
nodejs
git
pavucontrol
zip unzip
modemmanager
modem-manager-gui
fastfetch
asciinema
zulu8
ffmpeg
imagemagick
(import ./sl.script.nix)
(import ./startsync.script.nix)
(import ./bright.script.nix)
(import ./nix-cmd.script.nix)
(import ./sshpc.script.nix)
];
programs.fish.enable = true;
# Use the GRUB 2 boot loader.
boot.loader.grub.enable = true;
# boot.loader.grub.efiSupport = true;
# boot.loader.grub.efiInstallAsRemovable = true;
# boot.loader.efi.efiSysMountPoint = "/boot/efi";
# Define on which hard drive you want to install Grub.
# hardware # boot.loader.grub.device = "/dev/sda"; # or "nodev" for efi only
# hardware config # networking.hostName = "TudbuT-NixX250"; # Define your hostname.
# Pick only one of the below networking options.
# networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
networking.networkmanager.enable = true; # Easiest to use and most distros use this by default.
hardware.bluetooth.enable = true;
services.blueman.enable = true;
#services.modemmanager.enable = true;
systemd.services.modem-manager.enable = true;
systemd.services.earlyoom.enable = true;
# Set your time zone.
time.timeZone = "Europe/Berlin";
# Configure network proxy if necessary
# networking.proxy.default = "http://user:password@proxy:port/";
# networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
# Select internationalisation properties.
# i18n.defaultLocale = "en_US.UTF-8";
#console = {
# font = "Lat2-Terminus16";
# keyMap = "de";
# useXkbConfig = true; # use xkb.options in tty.
#;
systemd.services.set_battery_threshold = {
enable = true;
script = ''
echo 90 | tee /sys/class/power_supply/BAT*/charge_control_end_threshold > /dev/null
'';
wantedBy = ["multi-user.target"];
serviceConfig = {
user = "root";
Type = "oneshot";
};
};
services.fprintd.enable = true;
# Enable the X11 windowing system.
services.xserver.enable = true;
services.xserver.windowManager.i3.enable = true;
services.xserver.windowManager.i3.extraPackages = with pkgs; [
dmenu
i3status
i3lock
libnotify
xss-lock
maim
xclip
clipit
];
services.logind.lidSwitch = "ignore";
# Configure keymap in X11
services.xserver.xkb.layout = "de";
# services.xserver.xkb.options = "eurosign:e,caps:escape";
# Enable CUPS to print documents.
# services.printing.enable = true;
# Enable sound.
hardware.pulseaudio.enable = true;
# OR
# services.pipewire = {
# enable = true;
# pulse.enable = true;
# };
# Enable touchpad support (enabled default in most desktopManager).
# services.libinput.enable = true;
# Define a user account. Don't forget to set a password with passwd.
users.users.tudbut = {
isNormalUser = true;
extraGroups = [ "wheel" "networkmanager" ]; # Enable sudo for the user.
};
users.defaultUserShell = pkgs.fish;
security.sudo.wheelNeedsPassword = false;
# Some programs need SUID wrappers, can be configured further or are
# started in user sessions.
# programs.mtr.enable = true;
# programs.gnupg.agent = {
# enable = true;
# enableSSHSupport = true;
# };
# List services that you want to enable:
# Enable the OpenSSH daemon.
services.openssh.enable = true;
# Open ports in the firewall.
# networking.firewall.allowedTCPPorts = [ ... ];
# networking.firewall.allowedUDPPorts = [ ... ];
# Or disable the firewall altogether.
networking.firewall.enable = false;
# Copy the NixOS configuration file and link it from the resulting system
# (/run/current-system/configuration.nix). This is useful in case you
# accidentally delete configuration.nix.
system.copySystemConfiguration = true;
# This option defines the first version of NixOS you have installed on this particular machine,
# and is used to maintain compatibility with application data (e.g. databases) created on older NixOS versions.
#
# Most users should NEVER change this value after the initial install, for any reason,
# even if you've upgraded your system to a new NixOS release.
#
# This value does NOT affect the Nixpkgs version your packages and OS are pulled from,
# so changing it will NOT upgrade your system - see https://nixos.org/manual/nixos/stable/#sec-upgrading for how
# to actually do that.
#
# This value being lower than the current NixOS release does NOT mean your system is
# out of date, out of support, or vulnerable.
#
# Do NOT change this value unless you have manually inspected all the changes it would make to your configuration,
# and migrated your data accordingly.
#
# For more information, see `man configuration.nix` or https://nixos.org/manual/nixos/stable/options#opt-system.stateVersion .
system.stateVersion = "24.05"; # Did you read the comment?
}